Serveurs de réseautage Unity

Vous trouverez ici le code source le plus récent pour les serveurs de réseautage Unity intégrés. La version actuelle est la 2.0.1f1 (compatible Unity 3.x) :

  • Pour une utilisation avec le serveur maître*. API
  • Requis pour le « punchthrough NAT », les deux parties doivent être connectées au même facilitateur.
  • Requis pour les tests de connexion, doit être hébergé sur un serveur avec 4 adresses IP uniques.
  • Utilisé pour acheminer le trafic des clients aux serveurs auxquels ils ne pourraient pas se connecter autrement. Ajoute beaucoup de latence au trafic.

Pour plus d'informations, consultez la page du manuel dédiée à la création d'un serveur maître.

Versions plus anciennes

Les derniers serveurs ne peuvent pas communiquer avec Unity 2.x. Le code source pour l'ancien serveur maître (compatible avec les versions 2.x) fourni avec le facilitateur est disponible ici.

Vous pouvez télécharger le code source pour le testeur de connexion compatible avec les versions 2.x ici.