August 2017 Security Update Advisory (CVE-2017-12939)

 

Vulnerabilities Details

Remediation Steps

FAQ

References

Vulnerability Details

CVE ID:

CVE-2017-12939

Type:

Remote Code Execution

Discovered:

2017/08/13

Discovered By:

Rio

Patch Availability:

2017/08/18

Affected Operating System:

Windows

Affected Versions:

All (Windows)

Severity:

High

Patch Versions:

Please note: The Mac version is provided as a courtesy for team environments using Windows and Mac. The Mac version is NOT affected by the identified vulnerability.

If a patch is not available for your version, please use the Mitigation Tool [6,7,8] (All Versions)

Vulnerability Details

An input string validation issue was identified in the Unity Editor affecting the Windows platform that could lead to Remote Code Execution (RCE), allowing an attacker to potentially execute code remotely in the user’s computer.

Remediation Steps

Determine the version of your Unity Editor

Open a Unity project

The Unity version is visible in the main window title.

description

In the File menu choose Help -> About Unity.

description

The Unity version is shown in the About Unity window.

description

Install Update

If your version of the Unity Editor is not one of the listed Patch Versions of the Vulnerabilities Details section above you can continue with the update installation as follows.

To install the update you can use the Unity Editor update checker available in the File menu Help -> Check for Updates.

description

Additionally, you can download and install the corresponding patch for your version of the Unity Editor. The download links are available in the Patch Versions of the Vulnerabilities Details section and in the References section.

Mitigation Tool

If your version of the Unity Editor is not listed, or you are unable to install the update at this time, you can use the Mitigation Tool Guide [7].

Please keep in mind the recommended action is to install a fixed version of the Unity Editor.

FAQ

What type of vulnerability was addressed in this update?

An input string validation issue was identified that could lead to remote code execution (RCE), allowing an attacker to potentially execute code remotely in the user’s computer.

What platforms are affected?

Windows only. Mac and Linux platforms are not affected by the identified vulnerability.

What versions of Unity are affected?

All versions of the Unity Editor running on Windows.

What versions of the Unity Editor are being patched?

We have released a patch for the following Unity versions: 5.3, 5.4, 5.5, 5.6, and 2017.1. The full details are listed on UNITY-SEC-884.

We will not be patching Unity 4.x, 5.0, 5.1, or 5.2.

Will my specific version be patched?

Unity will be releasing a single patch to each of the most current dot-releases of Unity. For example, users running an older version of Unity 5.3 will need to update to the patched version of 5.3.8. There will be no patches for 5.3.7, 5.3.6, etc.

What about versions older than 5.3?

We are providing a workaround tool that disables the identified vulnerable Unity Editor feature, which can be downloaded from Mitigation Tool Guide[7]. Please understand, though, that the workaround is not a patch and has limitations. The workaround will disable the Unity Editor feature identified as vulnerable, but since we can’t control whether the affected functionality becomes re-enabled at some point after applying the workaround (system changes, reinstallations, etc.), we strongly recommend updating to the latest version of Unity to get the benefits of the full patch. You will also no longer be able to use the ‘Open in Unity’ functionality in the web browser version of the Asset Store after applying the workaround.

Does the workaround tool work for versions newer than 5.3? Can I use the workaround tool instead of patching?

The workaround tool can be used on all affected versions of Unity. Please understand, though, that the workaround is not a patch and has limitations: the workaround will disable the identified vulnerable Editor features, but since we can’t control whether the affected functionality becomes re-enabled at some point after applying the workaround (system changes, reinstallations, etc.), we strongly recommend updating to a patched version. You will also no longer be able to use the ‘Open in Unity’ functionality in the web browser version of the Asset Store after applying the workaround.

I run multiple versions of Unity, do I have to apply the workaround tool for all of them?

No, by running it once it deactivates the identified vulnerable component across all of them. Do keep in mind that by re-installing or updating (one) of the versions, it may activate the component again. To check, re-run the workaround tool until all versions are up to date.

Can I just use the workaround and never move to a patched version?

The workaround will disable the Unity Editor feature identified as vulnerable, but since we can’t control whether the affected functionality becomes re-enabled at some point after applying the workaround (system changes, reinstallations, etc.), we strongly recommend updating to a patched version. You will also no longer be able to use the ‘Open in Unity’ functionality in the web browser version of the Asset Store after applying the workaround.

I have a locked-down older version of Unity 5.x.x. Will you produce a patch for the exact version of Unity that I’m using?

Our focus right now is on addressing the identified vulnerability in the most current version of each dot-release. We don’t have any details to share on patches for other versions at this time.

Will I need to rebuild asset bundles due to the update requirement?

It depends on the specific version of Unity that you are using. Most customers will be able to update to the patched versions without needing to rebuild their bundles, but some customers may find that asset importers have been updated between the version they’re currently using and the patch for that dot-release. For those customers, asset bundle rebuilding may be necessary.

You definitely won’t need to rebuild bundles if you’re currently using 5.3.8p1, 5.4.5p4, 5.5.4p2, 5.6.3f1, or 2017.1.0p3.

How do I know if I’ll need to rebuild my asset bundles?

You may need to rebuild your bundles if any assets are re-imported when you first open your project in the patched version of Unity.

References